diff mbox series

[bug#42117,03/17] gnu: Add r-gpfit.

Message ID 20200629055042.8565-3-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42117,01/17] gnu: Add r-hardhat. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 29, 2020, 5:50 a.m. UTC
8 gnu/packages/cran.scm (r-gpfit): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d8e8a88baa..f101ccd285 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22391,3 +22391,26 @@  challenging.  The goal of @code{workflows} is to streamline this
 process by bundling the model alongside the preprocessor, all within
 the same object.")
     (license license:expat)))
+
+(define-public r-gpfit
+  (package
+    (name "r-gpfit")
+    (version "1.0-8")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "GPfit" version))
+        (sha256
+          (base32
+            "05mpiyi2vxv0wqp422n1mnxa8msc4daq40cwpnpngbcwqhlgqkby"))))
+    (properties `((upstream-name . "GPfit")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-lattice" ,r-lattice) ("r-lhs" ,r-lhs)))
+    (home-page
+      "https://cran.r-project.org/web/packages/GPfit/")
+    (synopsis "Gaussian Processes Modeling")
+    (description
+      "This package provides a computationally stable approach of
+fitting a Gaussian Process (GP) model to a deterministic simulator.")
+    (license license:gpl2)))