diff mbox series

[bug#42117,14/17] gnu: Add r-tidytext.

Message ID 20200629055042.8565-14-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42117,01/17] gnu: Add r-hardhat. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 29, 2020, 5:50 a.m. UTC
* gnu/packages/cran.scm (r-tidytext): New variable.
---
 gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3c98bc2753..37afec7774 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22734,3 +22734,37 @@  the @code{spelling} package which builds on this package to automate
 checking of files, documentation and vignettes in all common
 formats.")
     (license (list license:gpl2 license:lgpl2.1 license:mpl1.1))))
+
+(define-public r-tidytext
+  (package
+    (name "r-tidytext")
+    (version "0.2.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "tidytext" version))
+        (sha256
+          (base32
+            "0gck3f039qkpkwn92jlyfan76w0xydg17bh6nsg9qlba7c35kzs6"))))
+    (properties `((upstream-name . "tidytext")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-dplyr" ,r-dplyr)
+        ("r-generics" ,r-generics)
+        ("r-hunspell" ,r-hunspell)
+        ("r-janeaustenr" ,r-janeaustenr)
+        ("r-matrix" ,r-matrix)
+        ("r-purrr" ,r-purrr)
+        ("r-rlang" ,r-rlang)
+        ("r-stopwords" ,r-stopwords)
+        ("r-stringr" ,r-stringr)
+        ("r-tokenizers" ,r-tokenizers)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+      "https://github.com/juliasilge/tidytext")
+    (synopsis
+      "Text Mining using 'dplyr', 'ggplot2', and Other Tidy Tools")
+    (description
+      "Text mining for word processing and sentiment analysis using
+@code{dplyr}, @code{ggplot2}, and other tidy tools.")
+    (license license:expat)))