diff mbox series

[bug#42117,02/17] gnu: Add r-workflows.

Message ID 20200629055042.8565-2-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42117,01/17] gnu: Add r-hardhat. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 29, 2020, 5:50 a.m. UTC
* gnu/packages/cran.scm (r-workflows): New variable.
---
 gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 97025dda09..d8e8a88baa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22358,3 +22358,36 @@  have.  The goal of @code{hardhat} is to reduce the burden around building
 new modeling packages by providing functionality for preprocessing,
 predicting, and validating input.")
     (license license:expat)))
+
+(define-public r-workflows
+  (package
+    (name "r-workflows")
+    (version "0.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "workflows" version))
+        (sha256
+          (base32
+            "14lzbszz7ybfzqa5zw1hfh81b8rbwwyza6x8nhpnknl6x4adqfql"))))
+    (properties `((upstream-name . "workflows")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-cli" ,r-cli)
+        ("r-ellipsis" ,r-ellipsis)
+        ("r-generics" ,r-generics)
+        ("r-glue" ,r-glue)
+        ("r-hardhat" ,r-hardhat)
+        ("r-parsnip" ,r-parsnip)
+        ("r-rlang" ,r-rlang)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+      "https://github.com/tidymodels/workflows")
+    (synopsis "Modeling Workflows")
+    (description
+      "Managing both a @code{parsnip} model and a preprocessor, such
+as a model formula or recipe from @code{recipes}, can often be
+challenging.  The goal of @code{workflows} is to streamline this
+process by bundling the model alongside the preprocessor, all within
+the same object.")
+    (license license:expat)))