diff mbox series

[bug#42117,16/17] gnu: Add r-infer.

Message ID 20200629055042.8565-16-peterloleungyau@gmail.com
State Accepted
Headers show
Series [bug#42117,01/17] gnu: Add r-hardhat. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 29, 2020, 5:50 a.m. UTC
* gnu/packages/cran.scm (r-infer): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cf259a795a..9f7f952217 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22805,3 +22805,33 @@  users to specify a model without having to remember the different
 argument names across different functions or computational
 engines (e.g. 'R', 'Spark', 'Stan', etc).")
     (license license:gpl2)))
+
+(define-public r-infer
+  (package
+    (name "r-infer")
+    (version "0.5.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "infer" version))
+        (sha256
+          (base32
+            "0m00xhzrvmskwj4jwncakwxhzivn9pyiylq4r8s6ny4yiwqg303m"))))
+    (properties `((upstream-name . "infer")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-dplyr" ,r-dplyr)
+        ("r-ggplot2" ,r-ggplot2)
+        ("r-glue" ,r-glue)
+        ("r-magrittr" ,r-magrittr)
+        ("r-purrr" ,r-purrr)
+        ("r-rlang" ,r-rlang)
+        ("r-tibble" ,r-tibble)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/tidymodels/infer")
+    (synopsis "Tidy Statistical Inference")
+    (description
+      "The objective of this package is to perform inference using an
+expressive statistical grammar that coheres with the tidy design
+framework.")
+    (license license:cc0)))