diff mbox series

[bug#37704,9/9] gnu: Add poetry.

Message ID 20191028094630.18002-9-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#37704,1/9] gnu: python-cleo: Update to 0.6.8. | expand

Commit Message

Tanguy LE CARROUR Oct. 28, 2019, 9:46 a.m. UTC
* gnu/packages/python-xyz.scm (poetry): New public variable.
---
 gnu/packages/python-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)

Comments

Mathieu Othacehe Oct. 28, 2019, 1:53 p.m. UTC | #1
> +             ;; Bug in poetry https://github.com/sdispater/poetry/issues/866.
> +             (invoke "sed" "-i" "-e" "s/from distutils.core/from setuptools/" "setup.py")

This line is too long.

Mathieu
Tanguy LE CARROUR Oct. 28, 2019, 2:39 p.m. UTC | #2
Le 10/28, Mathieu Othacehe a écrit :
> > +daemon. It is the client side software which allows storing values in one or
>           ^
>           two spaces
> > +more, possibly remote, memcached servers. Search google for memcached for more
> > +information.
>
> Please remove the last sentence.

*Outch*, sorry! Copy/paste is **not** your friend! … done!


> > +     "CliKit is a group of utilities to build beautiful and testable
> > +command line interfaces.")
>
> Avoid adjectives such as beautiful. Please elaborate a bit on what are
> the features of this package.

Done!


> > +    (synopsis "MessagePack (de)serializer")
> > +    (description "MessagePack (de)serializer.")
>
> Please make full sentences for description. Elaborate on both fields.

Done!


> > +             ;; Bug in poetry https://github.com/sdispater/poetry/issues/866.
> > +             (invoke "sed" "-i" "-e" "s/from distutils.core/from setuptools/" "setup.py")
>
> This line is too long.

Neither etc/indent-code.el nor `guix lint` complained!? Fixed anyway!

I'm sending v3…

Thanks for reviewing!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2b3414454..e7d04befda 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10749,6 +10749,52 @@  powerful API: thread-safety; decorator syntax; support for memcached, redis,
 database, file, dict stores.  Cachy supports python versions 2.7+ and 3.2+.")
     (license license:expat)))
 
+(define-public poetry
+  (package
+    (name "poetry")
+    (version "0.12.17")
+    ;; Poetry can only be built from source with poetry.
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "poetry" version))
+       (sha256
+        (base32
+         "0gxwcd65qjmzqzppf53x51sic1rbcd9py6cdzx3aprppipimslvf"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f ;; Pypi does not have tests.
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'build
+           (lambda _
+             ;; Bug in poetry https://github.com/sdispater/poetry/issues/866.
+             (invoke "sed" "-i" "-e" "s/from distutils.core/from setuptools/" "setup.py")
+             #t)))))
+    (propagated-inputs
+     `(("python-cachecontrol" ,python-cachecontrol)
+       ("python-cachy" ,python-cachy)
+       ("python-cleo" ,python-cleo)
+       ("python-glob2" ,python-glob2)
+       ("python-html5lib" ,python-html5lib)
+       ("python-jsonschema" ,python-jsonschema)
+       ("python-msgpack" ,python-msgpack)
+       ("python-pathlib2" ,python-pathlib2)
+       ("python-pkginfo" ,python-pkginfo)
+       ("python-pyparsing" ,python-pyparsing)
+       ("python-pyrsistent" ,python-pyrsistent)
+       ("python-requests" ,python-requests)
+       ("python-requests-toolbelt" ,python-requests-toolbelt)
+       ("python-shellingham" ,python-shellingham)
+       ("python-tomlkit" ,python-tomlkit)
+       ("python-virtualenv" ,python-virtualenv)))
+    (home-page "https://poetry.eustace.io/")
+    (synopsis "Python dependency management and packaging made easy")
+    (description "Poetry is a tool for dependency management and packaging
+in Python.  It allows you to declare the libraries your project depends on and
+it will manage (install/update) them for you.")
+    (license license:expat)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")