diff mbox series

[bug#37704,6/9] gnu: Add python-msgpack-python.

Message ID 20191028094630.18002-6-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#37704,1/9] gnu: python-cleo: Update to 0.6.8. | expand

Commit Message

Tanguy LE CARROUR Oct. 28, 2019, 9:46 a.m. UTC
* gnu/packages/python-xyz.scm (python-msgpack-python): New public variable.
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Mathieu Othacehe Oct. 28, 2019, 1:48 p.m. UTC | #1
> +    (synopsis "MessagePack (de)serializer")
> +    (description "MessagePack (de)serializer.")

Please make full sentences for description. Elaborate on both fields.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8236b26d16..d53864794e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10704,6 +10704,23 @@  information.")
 command line interfaces.")
     (license license:expat)))
 
+(define-public python-msgpack-python
+  (package
+    (name "python-msgpack-python")
+    (version "0.5.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "msgpack-python" version))
+       (sha256
+        (base32
+         "16wh8qgybmfh4pjp8vfv78mdlkxfmcasg78lzlnm6nslsfkci31p"))))
+    (build-system python-build-system)
+    (home-page "http://msgpack.org/")
+    (synopsis "MessagePack (de)serializer")
+    (description "MessagePack (de)serializer.")
+    (license license:asl2.0)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")