diff mbox series

[bug#37704,5/9] gnu: Add python-clikit.

Message ID 20191028094630.18002-5-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#37704,1/9] gnu: python-cleo: Update to 0.6.8. | expand

Commit Message

Tanguy LE CARROUR Oct. 28, 2019, 9:46 a.m. UTC
* gnu/packages/python-xyz.scm (python-clikit): New public variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Mathieu Othacehe Oct. 28, 2019, 1:47 p.m. UTC | #1
> +     "CliKit is a group of utilities to build beautiful and testable
> +command line interfaces.")

Avoid adjectives such as beautiful. Please elaborate a bit on what are
the features of this package.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4aa422ffd6..8236b26d16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10682,6 +10682,28 @@  more, possibly remote, memcached servers. Search google for memcached for more
 information.")
     (license license:psfl)))
 
+(define-public python-clikit
+  (package
+    (name "python-clikit")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "clikit" version))
+       (sha256
+        (base32
+         "0dc8czib5f4j9px1ivcpqnmivnx2zjpc0xb00ldrhsqylks7r06n"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pastel" ,python-pastel)
+       ("python-pylev" ,python-pylev)))
+    (home-page "https://github.com/sdispater/clikit")
+    (synopsis "Group of utilities to build command line interfaces")
+    (description
+     "CliKit is a group of utilities to build beautiful and testable
+command line interfaces.")
+    (license license:expat)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")