diff mbox series

[bug#37704,3/9] gnu: Add python-shellingham.

Message ID 20191028094630.18002-3-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#37704,1/9] gnu: python-cleo: Update to 0.6.8. | expand

Commit Message

Tanguy LE CARROUR Oct. 28, 2019, 9:46 a.m. UTC
* gnu/packages/python-xyz.scm (python-shellingham): New public variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6b3db83b4..0199721e97 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10639,6 +10639,26 @@  create new TOML documents from scratch using the provided helpers.  Part of the
 implementation as been adapted, improved and fixed from Molten.")
     (license license:expat)))
 
+(define-public python-shellingham
+  (package
+    (name "python-shellingham")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shellingham" version))
+       (sha256
+        (base32
+         "1q7kws7w4x2hji3g7y0ni9ddk4sd676ylrb3db54gbpys6xj6nwq"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/sarugaku/shellingham")
+    (synopsis "Tool to Detect Surrounding Shell")
+    (description
+     "Shellingham detects what shell the current Python executable is
+running in.")
+    (license license:isc)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")