diff mbox series

[bug#37234,06/21] gnu: python-docker-py: Propagate runtime dependency.

Message ID 20190830142539.28376-6-mbakke@fastmail.com
State Accepted
Headers show
Series MLflow | expand

Commit Message

Marius Bakke Aug. 30, 2019, 2:25 p.m. UTC
* gnu/packages/docker.scm (python-docker-py)[inputs]: Move
PYTHON-WEBSOCKET-CLIENT from here ...
[propagated-inputs]: ... to here.
---
 gnu/packages/docker.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 94cfa2bdb7..bf83c96e7b 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -65,11 +65,11 @@ 
      `(("python-requests" ,python-requests-2.20)
        ("python-ipaddress" ,python-ipaddress)
        ("python-six" ,python-six)
-       ("python-urllib3" ,python-urllib3-1.24)
-       ("python-websocket-client" ,python-websocket-client)))
+       ("python-urllib3" ,python-urllib3-1.24)))
     (propagated-inputs
      `(("python-docker-pycreds" ,python-docker-pycreds)
-       ("python-paramiko" ,python-paramiko))) ; adds SSH support
+       ("python-paramiko" ,python-paramiko) ;adds SSH support
+       ("python-websocket-client" ,python-websocket-client))) ;imported by api/client.py
     (home-page "https://github.com/docker/docker-py/")
     (synopsis "Python client for Docker")
     (description "Docker-Py is a Python client for the Docker container