diff mbox series

[bug#37234,05/21] gnu: Add python-minio.

Message ID 20190830142539.28376-5-mbakke@fastmail.com
State Accepted
Headers show
Series MLflow | expand

Commit Message

Marius Bakke Aug. 30, 2019, 2:25 p.m. UTC
* gnu/packages/python-web.scm (python-minio): New public variable.
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9966f66d8f..7454fe8793 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -523,6 +523,34 @@  C, yielding parse times that can be a thirtieth of the html5lib parse times.")
 (define-public python2-html5-parser
   (package-with-python2 python-html5-parser))
 
+(define-public python-minio
+  (package
+    (name "python-minio")
+    (version "4.0.20")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "minio" version))
+              (sha256
+               (base32
+                "03z96iri7xl74p76blz72x09bjwh4qx2y6jxzv10vjssp4mx6499"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-faker" ,python-faker)
+       ("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-certifi" ,python-certifi)
+       ("python-dateutil" ,python-dateutil)
+       ("python-future" ,python-future)
+       ("python-pytz" ,python-pytz)
+       ("python-urllib3" ,python-urllib3)))
+    (home-page "https://github.com/minio/minio-py")
+    (synopsis "Programmatically access Amazon S3 from Python")
+    (description
+     "This package provides a Python library that allows you to interact with
+any Amazon S3 compatible object storage server.")
+    (license license:asl2.0)))
+
 (define-public python-pycurl
   (package
     (name "python-pycurl")