diff mbox series

[bug#37234,14/21] gnu: Add python-jsondiff.

Message ID 20190830142539.28376-14-mbakke@fastmail.com
State Accepted
Headers show
Series MLflow | expand

Commit Message

Marius Bakke Aug. 30, 2019, 2:25 p.m. UTC
* gnu/packages/python-web.scm (python-jsondiff): New public variable.
---
 gnu/packages/python-web.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a169279fcc..6695bd5e39 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -389,6 +389,27 @@  Swartz.")
 (define-public python2-html2text
   (package-with-python2 python-html2text))
 
+(define-public python-jsondiff
+  (package
+    (name "python-jsondiff")
+    (version "1.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jsondiff" version))
+              (sha256
+               (base32
+                "08dfs98xi7ick0mp1bkcvmw66ki3cs25nln7g8xqyjmaxj51663y"))))
+    (build-system python-build-system)
+    (arguments
+     ;; XXX: Tests depend on an unmaintained library called "nose-random".
+     `(#:tests? #f))
+    (home-page "https://github.com/xlwings/jsondiff")
+    (synopsis "Diff JSON and JSON-like structures in Python")
+    (description
+     "This package provides facilities for inspecting differences between
+data structures such as JSON, dictionaries, and sets.")
+    (license license:expat)))
+
 (define-public python-jsonpickle
   (package
     (name "python-jsonpickle")