diff mbox series

[bug#37234,16/21] gnu: Add python-boto.

Message ID 20190830142539.28376-16-mbakke@fastmail.com
State Accepted
Headers show
Series MLflow | expand

Commit Message

Marius Bakke Aug. 30, 2019, 2:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-boto): New public variable.
---
 gnu/packages/python-xyz.scm | 42 +++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 016fc4460c..7d4b0be494 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8752,6 +8752,48 @@  document.")
 (define-public python2-jmespath
   (package-with-python2 python-jmespath))
 
+(define-public python-boto
+  (package
+    (name "python-boto")
+    (version "2.49.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "boto" version))
+              (sha256
+               (base32
+                "0njy09c4wjx7ipxhwi6vv404nflyiasl78vwwxxpclnql903n3ga"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'prepare-tests
+                    (lambda _
+                      ;; The SSH tests requires HOME with a .ssh directory.
+                      (setenv "HOME" "/tmp")
+                      (mkdir "/tmp/.ssh")
+                      (call-with-output-file "/tmp/.ssh/authorized_keys"
+                        (const #t))
+                      (call-with-output-file "/tmp/.ssh/known_hosts"
+                        (const #t))
+                      #t))
+                  (replace 'check
+                    (lambda _
+                      (invoke "python" "tests/test.py" "default"))))))
+    (native-inputs
+     `(("python-httpretty" ,python-httpretty)
+       ("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-paramiko" ,python-paramiko)
+       ("python-requests" ,python-requests)))
+    (home-page "https://github.com/boto/boto")
+    (synopsis "Python interfaces for Amazon Web Services")
+    (description
+     "This package provides various facilities for interacting with Amazon
+Web Services through Python.
+
+This software is unmaintained, and new projects should use @code{boto3} instead.")
+    (license license:expat)))
+
 (define-public python-botocore
   (package
     (name "python-botocore")