diff mbox series

[bug#36663,08/14] gnu: Add ghc-readable

Message ID 20190715111412.74324-8-rob@vllmrt.net
State Accepted
Headers show
Series Add elm compiler dependencies | expand

Commit Message

Robert Vollmert July 15, 2019, 11:14 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-readable): New field.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9cfab15381..f845883589 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -57,3 +57,26 @@ 
      "The package language-glsl is a Haskell library for the representation,
 the parsing, and the pretty-printing of GLSL 1.50 code.")
     (license license:bsd-3)))
+
+(define-public ghc-readable
+  (package
+    (name "ghc-readable")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/readable/readable-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1ja39cg26wy2fs00gi12x7iq5k8i366pbqi3p916skfa5jnkfc3h"))))
+    (build-system haskell-build-system)
+    (home-page
+     "https://github.com/mightybyte/readable")
+    (synopsis "Reading from Text and ByteString")
+    (description
+     "Provides a Readable type class for reading data types from ByteString
+and Text.  Also includes efficient implementations for common data types.")
+    (license license:bsd-3)))