diff mbox series

[bug#36663,04/14] gnu: Add ghc-http-common

Message ID 20190715111412.74324-4-rob@vllmrt.net
State Accepted
Headers show
Series Add elm compiler dependencies | expand

Commit Message

Robert Vollmert July 15, 2019, 11:14 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-http-common): New field.
---
 gnu/packages/haskell-web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index f0ba23ce2e..b176287ed2 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1456,3 +1456,37 @@  library to hande the streaming IO.  The API is optimized for ease of use
 for the rather common case of code needing to query web services and deal
 with the result.")
     (license license:bsd-3)))
+
+(define-public ghc-http-common
+  (package
+    (name "ghc-http-common")
+    (version "0.8.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/http-common/http-common-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "14s5a178sb2vm5k00rs21760mds5dz2gs10k9iyn22h01mxyf599"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-base64-bytestring" ,ghc-base64-bytestring)
+       ("ghc-blaze-builder" ,ghc-blaze-builder)
+       ("ghc-case-insensitive" ,ghc-case-insensitive)
+       ("ghc-network" ,ghc-network)
+       ("ghc-unordered-containers"
+        ,ghc-unordered-containers)))
+    (home-page
+     "https://github.com/afcowie/http-streams/")
+    (synopsis
+     "Common types for HTTP clients and servers")
+    (description
+     "Base types used by a variety of HTTP clients and servers.
+See http-streams Network.Http.Client or pipes-http Pipes.Http.Client
+for full documentation.  You can import Network.Http.Types if you like,
+but both http-streams and pipes-http re-export this package's types and
+functions.")
+    (license license:bsd-3)))