diff mbox series

[bug#36663,12/14] gnu: Add ghc-prettyclass

Message ID 20190715111412.74324-12-rob@vllmrt.net
State Accepted
Headers show
Series Add elm compiler dependencies | expand

Commit Message

Robert Vollmert July 15, 2019, 11:14 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-prettyclass): New field.
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 43d04b0563..7763b94ae4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -195,3 +195,28 @@  primitives for I/O using streams.")
     (description
      "Low-level bindings to the zlib package.")
     (license license:bsd-3)))
+
+(define-public ghc-prettyclass
+  (package
+    (name "ghc-prettyclass")
+    (version "1.0.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/prettyclass/prettyclass-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "11l9ajci7nh1r547hx8hgxrhq8mh5gdq30pdf845wvilg9p48dz5"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/prettyclass")
+    (synopsis
+     "Pretty printing class similar to Show")
+    (description
+     "Pretty printing class similar to Show, based on the HughesPJ
+pretty printing library.  Provides the pretty printing class and
+instances for the Prelude types.")
+    (license license:bsd-3)))