diff mbox series

[bug#36663,13/14] gnu: Add ghc-threads

Message ID 20190715111412.74324-13-rob@vllmrt.net
State Accepted
Headers show
Series Add elm compiler dependencies | expand

Commit Message

Robert Vollmert July 15, 2019, 11:14 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-threads): New field.
---
 gnu/packages/haskell-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7763b94ae4..f8a063a7dd 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -220,3 +220,42 @@  primitives for I/O using streams.")
 pretty printing library.  Provides the pretty printing class and
 instances for the Prelude types.")
     (license license:bsd-3)))
+
+(define-public ghc-threads
+  (package
+    (name "ghc-threads")
+    (version "0.5.1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/threads/threads-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0bjnjhnq3km6xqk0fn1fgyz5xdw4h6lylbwwbcmkkfzwcz0c76hk"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-concurrent-extra" ,ghc-concurrent-extra)
+       ("ghc-hunit" ,ghc-hunit)
+       ("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-hunit"
+        ,ghc-test-framework-hunit)))
+    (home-page
+     "https://github.com/basvandijk/threads")
+    (synopsis
+     "Fork threads and wait for their result")
+    (description
+     "This package provides functions to fork threads and wait for their
+result, whether it's an exception or a normal value.
+Besides waiting for the termination of a single thread this packages also
+provides functions to wait for a group of threads to terminate.
+This package is similar to the threadmanager, async and spawn packages.
+The advantages of this package are:
+* Simpler API.
+* More efficient in both space and time.
+* No space-leak when forking a large number of threads.
+* Correct handling of asynchronous exceptions.
+* GHC specific functionality like forkOn and forkIOWithUnmask.")
+    (license license:bsd-3)))