diff mbox series

[bug#35446,v2,21/24] gnu: calibre: Install man pages.

Message ID 20190503164232.1799-21-mail@brendan.scot
State Accepted
Headers show
Series [bug#35446,v2,01/24] gnu: calibre: Update to 3.41.3. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brendan Tildesley May 3, 2019, 4:42 p.m. UTC
* gnu/packages/ebook.scm (calibre): Install man pages.
---
 gnu/packages/ebook.scm | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 94d3b9a43a..4bdba38c2a 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -203,6 +203,12 @@ 
              (invoke "python2" "setup.py" "mathjax""--system-mathjax" "--path-to-mathjax"
                      (string-append (assoc-ref inputs "js-mathjax") "/share/javascript/mathjax"))
              (invoke "python2" "setup.py" "rapydscript")))
+         (add-after 'install 'install-man-pages
+           (lambda* (#:key outputs #:allow-other-keys)
+             (copy-recursively
+              "man-pages"
+              (string-append (assoc-ref outputs "out") "/share/man"))
+             #t))
          ;; The font TTF files are used in some miscellaneous tests, so we
          ;; unbundle them here to avoid patching the tests.
          (add-after 'install 'unbundle-font-liberation