diff mbox series

[bug#35446,v2,10/24] gnu: calibre: Disable tests that require networking.

Message ID 20190503164232.1799-10-mail@brendan.scot
State Accepted
Headers show
Series [bug#35446,v2,01/24] gnu: calibre: Update to 3.41.3. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Brendan Tildesley May 3, 2019, 4:42 p.m. UTC
* gnu/packages/ebook.scm (calibre)[configure]: set CI=true so Bonjour test
doesn't try to run without networking.
---
 gnu/packages/ebook.scm | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 79fa99cf4a..2b557ab08d 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -185,6 +185,9 @@ 
                   "/bin/pdftohtml\"")))
               (setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
               (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))
+              ;; This informs the tests we are a continuous integration
+              ;; environment and thus have no networking.
+              (setenv "CI" "true")
               #t)))
          (add-after 'build 'build-extra
            (lambda* (#:key inputs #:allow-other-keys)