diff mbox series

[bug#55831,1/8] gnu: Add python-starlette.

Message ID 097ec178719a714171c095b0d584c57c833e4d6e.1654720996.git.peter@polidoro.io
State New
Headers show
Series Add platformio and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro June 8, 2022, 8:55 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-starlette): New variable.
---
 gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06a0d2593b..9a3a11c7d1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1200,6 +1200,30 @@  (define-public python-h2
 Python HTTP implementation.")
     (license license:expat)))
 
+(define-public python-starlette
+  (package
+    (name "python-starlette")
+    (version "0.20.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "starlette" version))
+              (sha256
+               (base32
+                "1si8plb5lgwkcaqzccrrisiksdrxldq94kij73i0mizn7l42g0nx"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-anyio
+                             python-typing-extensions
+                             python-itsdangerous
+                             python-jinja2
+                             python-multipart
+                             python-pyyaml
+                             python-requests))
+    (home-page "https://github.com/encode/starlette")
+    (synopsis "Lightweight ASGI framework for building async web services in Python")
+    (description "This package is a lightweight Asynchronous Server Gateway Interface for
+building async web services in Python.")
+    (license license:bsd-3)))
+
 (define-public python-sockjs-tornado
   (package
     (name "python-sockjs-tornado")