diff mbox series

[bug#55831,7/8] gnu: python-semantic-version: Update to 2.10.0.

Message ID 3366643273e11b1571db78ab2e0190fe2de13aff.1654720996.git.peter@polidoro.io
State New
Headers show
Series Add platformio and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro June 8, 2022, 8:55 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-semantic-version): Update to 2.10.0.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++--
 1 file changed, 20 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 94948fe4e2..3f19fb363f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1761,15 +1761,33 @@  (define-public python-filelock
 (define-public python-semantic-version
   (package
     (name "python-semantic-version")
-    (version "2.8.5")
+    (version "2.10.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "semantic_version" version))
        (sha256
         (base32
-         "0m4avx8zdkzc7qglv5zlr54g8yna5vl098drg5396ql7aph2vjyj"))))
+         "0704smz9k6hdd6i5xh0xf0sk47kannjb77abilvvp34r6v9vdaxx"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               ;; Skip the only failing test "test_django" because settings
+               ;; are not configured.
+               (invoke "pytest" "-vv" "-k" "not test_django")))))))
+    (native-inputs (list python-check-manifest
+                         python-colorama
+                         python-coverage
+                         python-django
+                         python-flake8
+                         python-nose2
+                         python-readme-renderer
+                         python-tox
+                         python-wheel))
     (home-page "https://github.com/rbarrois/python-semanticversion")
     (synopsis "Semantic versioning module for Python")
     (description