mbox series

[bug#55831,0/8] Add platformio and dependencies

Message ID cover.1654720996.git.peter@polidoro.io
Headers show
Series Add platformio and dependencies | expand

Message

Peter Polidoro June 8, 2022, 8:55 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>


Platformio is a python package that required adding some new packages and
updating others. Most of the updates were relatively straightforward, but
python-httpcore and python-httpx seem to have cyclic dependencies on each
other, so those updates are included as a single commit. Some of these updates
may affect packages not included in this patch series. For example, several
python packages specify a dependency on h11 less than 0.13.0. If necessary,
those guix packages can be updated to relax that requirement or version 0.12.0
could be added if that dependency restriction is indeed necessary.


Peter Polidoro (8):
  gnu: Add python-starlette.
  gnu: python-h11: Update to 0.13.0.
  gnu: python-wsproto: Update to 1.1.0.
  gnu: python-httpcore and python-httpx: Update to 0.15.0 and 0.23.0
  gnu: python-sanic-testing: Update requirements.
  gnu: python-aiofiles: Update to 0.8.0.
  gnu: python-semantic-version: Update to 2.10.0.
  gnu: Add platformio.

 gnu/packages/embedded.scm   | 59 ++++++++++++++++++++++++++++++++
 gnu/packages/python-web.scm | 67 ++++++++++++++++++++++++++++++-------
 gnu/packages/python-xyz.scm | 26 +++++++++++---
 3 files changed, 136 insertions(+), 16 deletions(-)