mbox series

[bug#51989,00/12] Add aws-vault and missing dependent packages

Message ID 87lf1j4u2n.fsf@rekahsoft.ca
Headers show
Series Add aws-vault and missing dependent packages | expand

Message

Collin J. Doering Nov. 19, 2021, 11:12 p.m. UTC
aws-vault is a tool to securely store and use aws credentials. This patch set packages aws-vault as well as missing dependencies.

Note: perhaps gnu/packages/golang.scm is not the best fit for these changes. Any suggestions for a better spot appreciated.

Collin J. Doering (12):
  gnu: Add go-keyring
  gnu: Add go-androidnsfix
  gnu: Add go-percent
  gnu: Add go-aws-sdk-go
  gnu: Add go-jose2go
  gnu: Add go-libsecret
  gnu: Add go-ini
  gnu: Add go-open-golang
  gnu: Add go-alecthomas-template
  gnu: Add go-alecthomas-units
  gnu: Add go-kingpin
  gnu: Add aws-vault

 gnu/packages/golang.scm | 380 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 380 insertions(+)

Comments

Ludovic Courtès Dec. 18, 2021, 6:56 p.m. UTC | #1
Hi Collin,

"Collin J. Doering" <collin@rekahsoft.ca> skribis:

> aws-vault is a tool to securely store and use aws credentials. This patch set packages aws-vault as well as missing dependencies.
>
> Note: perhaps gnu/packages/golang.scm is not the best fit for these changes. Any suggestions for a better spot appreciated.

Hmm not sure; most of the dependencies are at home in golang.scm IMO.
I’d leave it as is.

> Collin J. Doering (12):
>   gnu: Add go-keyring
>   gnu: Add go-androidnsfix
>   gnu: Add go-percent
>   gnu: Add go-aws-sdk-go
>   gnu: Add go-jose2go
>   gnu: Add go-libsecret
>   gnu: Add go-ini
>   gnu: Add go-open-golang
>   gnu: Add go-alecthomas-template
>   gnu: Add go-alecthomas-units
>   gnu: Add go-kingpin
>   gnu: Add aws-vault

I tried to apply those (overall it LGTM), but the order is incorrect:
for instance ‘go-keyring’ depends on ‘go-percent’ and ‘go-libsecret’.

So I have the following queries:

  1. Do you think you could send them in the “right order”?

  2. As you go, could you pass them to:

      ./pre-inst-env guix style PKG

     ?

  3. Last, it would be perfect if you could provide the conventional
     commit logs.

Thanks in advance, and sorry for the delay!

Ludo’.
Leo Famulari Dec. 18, 2021, 7:45 p.m. UTC | #2
On Sat, Dec 18, 2021 at 07:56:02PM +0100, Ludovic Courtès wrote:
>   1. Do you think you could send them in the “right order”?

The easiest way to do this is to send all the patches in a single file:

`git format-patch origin/master --stdout > vault.patch` and then mail
'vault.patch'.