diff mbox series

[bug#51989,02/12] gnu: Add go-androidnsfix

Message ID 87czmv4tyb.fsf@rekahsoft.ca
State Accepted
Headers show
Series Add aws-vault and missing dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Collin J. Doering Nov. 19, 2021, 11:16 p.m. UTC
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9d7b4e6d02..4eeb3e6af0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8883,3 +8883,26 @@  (define-public go-keyring
     (home-page "https://github.com/99designs/keyring")
     (license license:expat)))
 
+(define-public go-github-com-androiddnsfix
+  (package
+    (name "go-androiddnsfix")
+    (version "ff02804463540c36e3a148dcf4b009d003cf2a31")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mtibben/androiddnsfix")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pcbjs793kd0yg3dcp79agfxm7xm3sldx2r7v66ipzpcq0j2npi2"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/mtibben/androiddnsfix"
+       #:phases %standard-phases))
+    (synopsis "Hack to get around the issues building on android")
+    (description
+     "Hack around the issues in https://github.com/golang/go/issues/8877.")
+    (home-page "https://github.com/mtibben/androiddnsfix")
+    (license license:expat)))
+