diff mbox series

[bug#51989,06/12] gnu: Add go-libsecret

Message ID 87v90n3f80.fsf@rekahsoft.ca
State Accepted
Headers show
Series Add aws-vault and missing dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Collin J. Doering Nov. 19, 2021, 11:19 p.m. UTC
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8c91cec335..10e472c72f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8980,3 +8980,32 @@  (define-public go-github-com-dvsekhvalnov-jose2go
     (home-page "https://github.com/dvsekhvalnov/jose2go")
     (license license:expat)))
 
+(define-public go-github-com-go-libsecret
+  (let ((commit "a6f4afe4910cad8688db3e0e9b9ac92ad22d54e1")
+        (revision "0"))
+    (package
+      (name "go-libsecret")
+      (version "5.0.1")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/gsterjov/go-libsecret")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "09zaiadnll83vs22ib89agg7anj0blw5fywvmckxllsgif6ak6v7"))))
+      (build-system go-build-system)
+      (native-inputs
+       `(("go-github-com-godbus-dbus" ,go-github-com-godbus-dbus)))
+      (arguments
+       '(#:import-path "github.com/gsterjov/go-libsecret"
+         #:phases %standard-phases))
+      (synopsis "Go library that manages secrets via the
+freedesktop.org Secret Service DBus API")
+      (description
+       "Native go library that manages secrets via the freedesktop.org Secret
+Service DBus API")
+      (home-page "https://github.com/gsterjov/go-libsecret")
+      (license license:expat))))
+