diff mbox series

[bug#51989,09/12] gnu: Add go-alecthomas-template

Message ID 87ilwn3f5i.fsf@rekahsoft.ca
State Accepted
Headers show
Series Add aws-vault and missing dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Collin J. Doering Nov. 19, 2021, 11:21 p.m. UTC
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c8174372c4..3944ee71fe 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9066,3 +9066,30 @@  (define-public go-github-com-skratchdot-open-golang
       (home-page "https://github.com/skratchdot/open-golang")
       (license license:expat))))
 
+(define-public go-github-com-alecthomas-template
+  (let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
+        (revision "0"))
+      (package
+        (name "go-alecthomas-template")
+        (version "0.0.0")
+        (source (origin
+                  (method git-fetch)
+                  (uri (git-reference
+                        (url "https://github.com/alecthomas/template")
+                        (commit commit)))
+                  (file-name (git-file-name name version))
+                  (sha256
+                   (base32
+                    "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj"))))
+        (build-system go-build-system)
+        (arguments
+         '(#:import-path "github.com/alecthomas/template"
+           #:phases %standard-phases))
+        (synopsis "Fork of Go's text/template adding newline elision")
+        (description
+         "This is a fork of Go 1.4's text/template package with one addition: a
+backslash immediately after a closing delimiter will delete all subsequent
+newlines until a non-newline.")
+        (home-page "https://github.com/alecthomas/template")
+        (license license:bsd-3))))
+