diff mbox series

[bug#62122,1/4] gnu: Add emacs-sphinx-doc.

Message ID 20230311144938.765-1-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#62122,1/4] gnu: Add emacs-sphinx-doc. | expand

Commit Message

Rostislav Svoboda March 11, 2023, 2:49 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-sphinx-doc): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Nicolas Goaziou March 17, 2023, 8:36 a.m. UTC | #1
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-sphinx-doc): New variable.

Thank you. Some comments follow.

> +(define-public emacs-sphinx-doc
> +  (let ((commit "1eda612a44ef027e5229895daa77db99a21b8801"))

Since you're using a non-tagged commit, you also need to bind revision
to "0" or "1". FWIW, I prefer latter because Repology thinks "version-0"
predates "version".

> +    (package
> +      (name "emacs-sphinx-doc")
> +      (version "0.1.0")

Base version is "0.3.0" according to Version keyword. Therefore, this should be

   (git-version "0.3.0" revision commit)

> +      (home-page
> +       "https://github.com/naiquevin/sphinx-doc.el")

You can use a single line here.

> +      (synopsis
> +       "Generate Sphinx friendly docstrings for Python functions")

Ditto. Maybe add "in Emacs" at the end?

> +      (description
> +       "Emacs minor mode for inserting docstring skeleton for Python functions
> +and methods.

This should be a full sentence.

  Sphinx Doc is an Emacs minor modeā€¦

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 509c640b78..11afbe7778 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12411,6 +12411,34 @@  (define-public emacs-spinner
 ongoing operations.")
     (license license:gpl3+)))
 
+(define-public emacs-sphinx-doc
+  (let ((commit "1eda612a44ef027e5229895daa77db99a21b8801"))
+    (package
+      (name "emacs-sphinx-doc")
+      (version "0.1.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/naiquevin/sphinx-doc.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0q72i95yx3xa57jlgr7dik6prf20hi8bp8xf3f5c6ificv7i5378"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash emacs-s))
+      (home-page
+       "https://github.com/naiquevin/sphinx-doc.el")
+      (synopsis
+       "Generate Sphinx friendly docstrings for Python functions")
+      (description
+       "Emacs minor mode for inserting docstring skeleton for Python functions
+and methods.  The structure of the docstring is as per the requirement of the
+Sphinx documentation generator.")
+      (license license:expat))))
+
 (define-public emacs-sparql-mode
   (package
     (name "emacs-sparql-mode")