diff mbox series

[bug#62123,3/4] gnu: Add emacs-pippel.

Message ID 20230311144938.765-3-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#62122,1/4] gnu: Add emacs-sphinx-doc. | expand

Commit Message

Rostislav Svoboda March 11, 2023, 2:49 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-pippel): New variable.
---
 gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d371cfd6f3..cbd0e64e65 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17358,6 +17358,44 @@  (define-public emacs-pinyinlib
 letter of Pinyin to Simplified/Traditional Chinese characters.")
     (license license:gpl3+)))
 
+(define-public emacs-pippel
+  (let ((commit "cb194952ee150e77601d3233dabdb521b976ee79")
+        (revision "0"))
+    (package
+      (name "emacs-pippel")
+      (version (git-version "1.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/arifer612/pippel")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "17606l24yyrjxa4rc0p2zj50lfbayqldw4phhi59yqf61289d520"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash emacs-s))
+      (inputs
+       (list python))
+      (arguments
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'substitute-curl-path
+              (lambda* (#:key inputs #:allow-other-keys)
+                (emacs-substitute-variables "plz.el"
+                  ("pippel-python-command" (search-input-file
+                                            inputs "/bin/python"))))))))
+      (home-page "https://github.com/arifer612/pippel")
+      (synopsis "Emacs frontend to Python package manager pip")
+      (description
+       "Emacs frontend for the Python package manager pip.  As pippel also uses
+@code{tabulated-list-mode}, it provides a similar package menu like
+@code{package-list-packages}.")
+      (license license:gpl3+))))
+
 (define-public emacs-reverse-im
   (package
     (name "emacs-reverse-im")