diff mbox series

[bug#62121,2/4] gnu: Add emacs-railscasts-theme.

Message ID 20230311144938.765-2-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#62122,1/4] gnu: Add emacs-sphinx-doc. | expand

Commit Message

Rostislav Svoboda March 11, 2023, 2:49 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-railscasts-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou March 17, 2023, 8:43 a.m. UTC | #1
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-railscasts-theme): New variable.

Thanks. Some comments follow.

> +      (home-page
> +       "https://github.com/mikenichols/railscasts-theme")

A single line should suffice above.

> +      (synopsis "Railscasts color theme for Emacs")
> +      (description "Railscasts color theme for Emacs.")

You need to provide a complete sentence. For example,

 Railscasts is a color theme for Emacs.

> +      (license license:expat-0))))

Isn't it plain expat?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 11afbe7778..d371cfd6f3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13392,6 +13392,29 @@  (define-public emacs-elpy
 completion, interactive development and more.")
       (license license:gpl3+))))
 
+(define-public emacs-railscasts-theme
+  (let ((commit "1340c3f6c2717761cab95617cf8dcbd962b1095b")
+        (revision "0"))
+    (package
+      (name "emacs-railscasts-theme")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mikenichols/railscasts-theme")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "021x1l5kzsbm0qj5a3bngxa7ickm4lbwsdz81a2ks9pi1ivmw205"))))
+      (build-system emacs-build-system)
+      (home-page
+       "https://github.com/mikenichols/railscasts-theme")
+      (synopsis "Railscasts color theme for Emacs")
+      (description "Railscasts color theme for Emacs.")
+      (license license:expat-0))))
+
 (define-public emacs-rainbow-delimiters
   (package
     (name "emacs-rainbow-delimiters")