diff mbox series

[bug#55962,6/9] gnu: Add node-pbf.

Message ID 20220614094954.15197-6-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#55958,1/9] gnu: Add node-buffer-crc32. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves June 14, 2022, 9:49 a.m. UTC
* gnu/packages/node-xyz.scm (node-pbf): New variable.
---
 gnu/packages/node-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Marius Bakke June 23, 2022, 9:10 p.m. UTC | #1
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

> * gnu/packages/node-xyz.scm (node-pbf): New variable.
> ---
>  gnu/packages/node-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index 3d945871cd..aa838108ad 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -233,6 +233,41 @@ (define-public node-oop
>  while being as light-weight and simple as possible.")
>        (license license:expat))))
>  
> +(define-public node-pbf
> +  (package
> +    (name "node-pbf")
> +    (version "3.2.1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/mapbox/pbf")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +          (base32
> +           "1r8xs787ix79yr0vrwrizdml9h7cmxjrzhvnhkj784ac5f8nv5j7"))))
> +    (build-system node-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (delete 'check)
> +         (replace 'configure
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> +                     "--offline" "--ignore-scripts" "install" "--production")
> +             #t)))))
> +    (inputs (list node-ieee754 node-resolve-protobuf-schema))
> +    (home-page "https://github.com/mapbox/pbf")
> +    (synopsis "Low-level library for decoding and encodingprotocol buffers in
> +Javascript")

Maybe "Decode and encode protocol buffers in Javascript"?

> +    (description "This package is a low-level, fast, ultra-lightweight (3KB
> +gzipped) JavaScript library for decoding and encoding protocol buffers, a
> +compact binary format for structured data serialization. Works both in Node and
> +the browser. Supports lazy decoding and detailed customization of the
> +reading/writing code.")

s/ultra-// and no need to mention the size.  Remember two spaces after
punctuation (or 'guix lint').  Otherwise great.  :-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 3d945871cd..aa838108ad 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -233,6 +233,41 @@  (define-public node-oop
 while being as light-weight and simple as possible.")
       (license license:expat))))
 
+(define-public node-pbf
+  (package
+    (name "node-pbf")
+    (version "3.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mapbox/pbf")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+          (base32
+           "1r8xs787ix79yr0vrwrizdml9h7cmxjrzhvnhkj784ac5f8nv5j7"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (replace 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+                     "--offline" "--ignore-scripts" "install" "--production")
+             #t)))))
+    (inputs (list node-ieee754 node-resolve-protobuf-schema))
+    (home-page "https://github.com/mapbox/pbf")
+    (synopsis "Low-level library for decoding and encodingprotocol buffers in
+Javascript")
+    (description "This package is a low-level, fast, ultra-lightweight (3KB
+gzipped) JavaScript library for decoding and encoding protocol buffers, a
+compact binary format for structured data serialization. Works both in Node and
+the browser. Supports lazy decoding and detailed customization of the
+reading/writing code.")
+    (license license:bsd-3)))
+
 (define-public node-protocol-buffers-schema
   (package
     (name "node-protocol-buffers-schema")