diff mbox series

[bug#55961,3/9] gnu: Add node-protocol-buffers-schema.

Message ID 20220614094954.15197-3-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#55958,1/9] gnu: Add node-buffer-crc32. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves June 14, 2022, 9:49 a.m. UTC
* gnu/packages/node-xyz.scm (node-protocol-buffers-schema): New variable.
---
 gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Marius Bakke June 23, 2022, 8:25 p.m. UTC | #1
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

> * gnu/packages/node-xyz.scm (node-protocol-buffers-schema): New variable.
> ---
>  gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index af3745f601..3f49955e29 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -233,6 +233,36 @@ (define-public node-oop
>  while being as light-weight and simple as possible.")
>        (license license:expat))))
>  
> +(define-public node-protocol-buffers-schema
> +  (package
> +    (name "node-protocol-buffers-schema")
> +    (version "3.6.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/mafintosh/protocol-buffers-schema")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +          (base32
> +           "0lnckxj14jzsnfxdd5kmlwrac43c214bv8i2g5rdldymlpxzrz1v"))))
> +    (build-system node-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (delete 'check)
> +         (replace 'configure
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> +                     "--offline" "--ignore-scripts" "install" "--production")
> +             #t)))))

Same comments as before regarding arguments and indentation.

> +    (home-page "https://github.com/mafintosh/protocol-buffers-schema")
> +    (synopsis "No nonsense protocol buffers schema parser written in Javascript")

Avoid marketing words such as "no-nonsense".  :-)

Otherwise LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index af3745f601..3f49955e29 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -233,6 +233,36 @@  (define-public node-oop
 while being as light-weight and simple as possible.")
       (license license:expat))))
 
+(define-public node-protocol-buffers-schema
+  (package
+    (name "node-protocol-buffers-schema")
+    (version "3.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mafintosh/protocol-buffers-schema")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+          (base32
+           "0lnckxj14jzsnfxdd5kmlwrac43c214bv8i2g5rdldymlpxzrz1v"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (replace 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+                     "--offline" "--ignore-scripts" "install" "--production")
+             #t)))))
+    (home-page "https://github.com/mafintosh/protocol-buffers-schema")
+    (synopsis "No nonsense protocol buffers schema parser written in Javascript")
+    (description "This package provides a protocol buffers schema parser written
+in Javascript.")
+    (license license:expat)))
+
 (define-public node-stack-trace
   ;; There have been improvements since the last release.
   (let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")