diff mbox series

[bug#55959,4/9] gnu: Add node-resolve-protobuf-schema.

Message ID 20220614094954.15197-4-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#55958,1/9] gnu: Add node-buffer-crc32. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves June 14, 2022, 9:49 a.m. UTC
* gnu/packages/node-xyz.scm (node-resolve-protobuf-schema): New variable.
---
 gnu/packages/node-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Marius Bakke June 23, 2022, 8:54 p.m. UTC | #1
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

> * gnu/packages/node-xyz.scm (node-resolve-protobuf-schema): New variable.
> ---
>  gnu/packages/node-xyz.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index 3f49955e29..8f3288f219 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -263,6 +263,37 @@ (define-public node-protocol-buffers-schema
>  in Javascript.")
>      (license license:expat)))
>  
> +(define-public node-resolve-protobuf-schema
> +  (package
> +    (name "node-resolve-protobuf-schema")
> +    (version "2.1.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/mafintosh/resolve-protobuf-schema")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +          (base32
> +           "0zxavr0b2yz9xzp6zlsg5g09i0a6zqb24j12rdvfgph6wd4mzk40"))))
> +    (build-system node-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (delete 'check)
> +         (replace 'configure
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> +                     "--offline" "--ignore-scripts" "install" "--production")
> +             #t)))))

Same comments as ... you get the drift.

> +    (inputs (list node-protocol-buffers-schema))
> +    (home-page "https://github.com/mafintosh/resolve-protobuf-schema")
> +    (synopsis "Read a protobuf schema from the disk, parse it and resolve all imports")

Maybe just "Resolve protobuf imports".

> +    (description "This package allows to read a protobuf schema from the disk,
> +parse it and resolve all imports.")

s/allows to/can/
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 3f49955e29..8f3288f219 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -263,6 +263,37 @@  (define-public node-protocol-buffers-schema
 in Javascript.")
     (license license:expat)))
 
+(define-public node-resolve-protobuf-schema
+  (package
+    (name "node-resolve-protobuf-schema")
+    (version "2.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mafintosh/resolve-protobuf-schema")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+          (base32
+           "0zxavr0b2yz9xzp6zlsg5g09i0a6zqb24j12rdvfgph6wd4mzk40"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (replace 'configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+                     "--offline" "--ignore-scripts" "install" "--production")
+             #t)))))
+    (inputs (list node-protocol-buffers-schema))
+    (home-page "https://github.com/mafintosh/resolve-protobuf-schema")
+    (synopsis "Read a protobuf schema from the disk, parse it and resolve all imports")
+    (description "This package allows to read a protobuf schema from the disk,
+parse it and resolve all imports.")
+    (license license:expat)))
+
 (define-public node-stack-trace
   ;; There have been improvements since the last release.
   (let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")