diff mbox series

[bug#55381,05/14] gnu: Add r-unglue.

Message ID 20c51184bbe6034ed7b4be6fc3f2b36f212ea60e.1651893551.git.kyle@posteo.net
State New
Headers show
Series [bug#55379,01/14] gnu: Add r-gpg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kyle May 12, 2022, 2:10 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

M May 14, 2022, 6:18 p.m. UTC | #1
kyle schreef op do 12-05-2022 om 02:10 [+0000]:
> Use syntax inspired by the package 'glue'

Shouldn't this be 'r-glue'?  Guix doesn't have a package named 'glue'.
Also, writing a description (+- = some factual statements) in the
imperative mood ... is technically possible, but I wouldn't recommend
it.  Referring to another package for more information on what 'rust-
unglue' is about is technically possible, but a bit cumbersome for the
reader I think.  Maybe you can re-use parts of the description of
'r-glue'.

>  to extract matched substrings in a
> +more intuitive and compact way than by using standard regular expressions.

This is a bit markety language.

More generally, upstream descriptions often aren't great and require
some tweaking, expanding (and sometimes abbreviation, though not in
this particular case).  The manual has some general guidelines in
(guix)Synopses and Descriptions.

FWIW, I consider 'emacs', 'hello' and 'sed' to have good descriptions,
though the emacs description goes a bit markety with ‘highly
customizable ... extensive documention on everything’ and such ...
though in the case of Emacs those claims appear to be actually true so
maybe it's a good description after all.

Greetings,
Maxime.
Ricardo Wurmus Dec. 29, 2022, 7:56 p.m. UTC | #2
Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 213f810d04..516c335822 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33338,6 +33338,26 @@  (define-public r-unpivotr
 with one other by their proximity in given directions.  Functions for data
 frames and HTML tables are provided.")
    (license license:expat)))
+
+(define-public r-unglue
+  (package
+   (name "r-unglue")
+   (version "0.1.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "unglue" version))
+     (sha256
+      (base32 "0w8ld4xllx0lj1jz8i2sj92f8136hlwri1d8ldpg1ymxj7aw93vg"))))
+   (properties `((upstream-name . "unglue")))
+   (build-system r-build-system)
+   (home-page "https://cran.r-project.org/package=unglue")
+   (synopsis "Extract Matched Substrings Using a Pattern")
+   (description
+    "Use syntax inspired by the package 'glue' to extract matched substrings in a
+more intuitive and compact way than by using standard regular expressions.")
+   (license license:gpl3)))
+
 (define r-gpg
   (package
    (name "r-gpg")