diff mbox series

[bug#55379,11/14] gnu: Add r-picosat.

Message ID 39718183c1f2cb1ca010bcb905d5f1b44ac9a47f.1651893551.git.kyle@posteo.net
State New
Headers show
Series [bug#55379,01/14] gnu: Add r-gpg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kyle May 12, 2022, 2:10 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f578cdfa2a..0c7a3d55ff 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33466,6 +33466,27 @@  (define-public r-relimp
     "This package provides functions to facilitate inference on the relative importance of predictors in a linear or generalized linear model, and a couple of useful Tcl/Tk widgets.")
    (license license:gpl2+)))
 
+(define-public r-rpicosat
+  (package
+   (name "r-rpicosat")
+   (version "1.0.1")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "rpicosat" version))
+     (sha256
+      (base32
+       "1zj2d6jairmvya91vhv9kpkf34zmzl9vlha5yvfjj0j0apmqc0li"))))
+   (properties `((upstream-name . "rpicosat")))
+   (build-system r-build-system)
+   (home-page
+    "https://github.com/dirkschumacher/rpicosat")
+   (synopsis
+    "R Bindings for the 'PicoSAT' SAT Solver")
+   (description
+    "Bindings for the 'PicoSAT' solver to solve Boolean satisfiability problems (SAT).  The boolean satisfiability problem asks the question if a given boolean formula can be TRUE; i.e.  does there exist an assignment of TRUE/FALSE for each variable such that the whole formula is TRUE? The package bundles 'PicoSAT' solver release 965 <http://www.fmv.jku.at/picosat/>.")
+   (license license:expat)))
+
 
 (define r-gpg
   (package