diff mbox series

[bug#55379,12/14] gnu: Add r-ryacas.

Message ID 4ac9c8db561a0486186ed4daabb36c4e801f5179.1651893551.git.kyle@posteo.net
State New
Headers show
Series [bug#55379,01/14] gnu: Add r-gpg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kyle May 12, 2022, 2:10 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0c7a3d55ff..a2a29f8cdb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33487,6 +33487,28 @@  (define-public r-rpicosat
     "Bindings for the 'PicoSAT' solver to solve Boolean satisfiability problems (SAT).  The boolean satisfiability problem asks the question if a given boolean formula can be TRUE; i.e.  does there exist an assignment of TRUE/FALSE for each variable such that the whole formula is TRUE? The package bundles 'PicoSAT' solver release 965 <http://www.fmv.jku.at/picosat/>.")
    (license license:expat)))
 
+(define-public r-ryacas
+  (package
+   (name "r-ryacas")
+   (version "1.1.3")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "Ryacas" version))
+     (sha256
+      (base32
+       "12vkylq06c7kqvvf662cyzhdcnpy928xsjflf1kf0nh6y00gywf8"))))
+   (properties `((upstream-name . "Ryacas")))
+   (build-system r-build-system)
+   (propagated-inputs (list r-magrittr r-rcpp))
+   (native-inputs (list r-knitr))
+   (home-page "https://github.com/r-cas/ryacas")
+   (synopsis
+    "R Interface to the 'Yacas' Computer Algebra System")
+   (description
+    "Interface to the 'yacas' computer algebra system (<http://www.yacas.org/>).")
+   (license (list license:gpl2+ license:gpl3+))))
+
 
 (define r-gpg
   (package