diff mbox series

[bug#49123,01/24] gnu: Add pyotherside.

Message ID 20210620010742.4259-1-0x2d@disroot.org
State New
Headers show
Series [bug#49123,01/24] gnu: Add pyotherside. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

slg June 20, 2021, 1:07 a.m. UTC
* gnu/packages/qt.scm (pyotherside): New variable.
---
 gnu/packages/qt.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

M July 19, 2021, 12:05 p.m. UTC | #1
slg via Guix-patches via schreef op za 19-06-2021 om 22:07 [-0300]:
> * gnu/packages/qt.scm (pyotherside): New variable.
> ---
>  gnu/packages/qt.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)
> 
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 19fcc2f37e..3e91a82a46 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -3044,3 +3044,36 @@ being fully customizable and easy to extend.")
>  also compatible with SGI and TGS Open Inventor, and the API is based on the API
>  of the InventorXt GUI component toolkit.")
>      (license license:bsd-3))))
> +
> +(define-public pyotherside
> +  (let ((commit-ref "8f7e67980f7ceb2d0fc40a9568d3b10c640a8d74")
> +        (revision "1"))
> +    (package
> +      (inherit qtsvg)

Why are you inheriting from 'qtsvg'?
'pyotherside' isn't a variant of 'qtsvg'.

> +      (name "pyotherside")
> +      (version (git-version "1.5.9" revision commit-ref))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/thp/pyotherside")
> +               (commit commit-ref)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1kq8v2inwx4j9idsdxwkjas4nqyfwzwfwiiwpjqr8ggcx1z9gvi3"))))

The source code seems ok.


> +         ((#:tests? _ #f) #f))) ;; Plugin must be installed before testing

You could move the 'check' phase after the 'install' phase,
then #:tests? #f might not be required.

> +      (license license:isc))))

This license seems correct.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 19fcc2f37e..3e91a82a46 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3044,3 +3044,36 @@  being fully customizable and easy to extend.")
 also compatible with SGI and TGS Open Inventor, and the API is based on the API
 of the InventorXt GUI component toolkit.")
     (license license:bsd-3))))
+
+(define-public pyotherside
+  (let ((commit-ref "8f7e67980f7ceb2d0fc40a9568d3b10c640a8d74")
+        (revision "1"))
+    (package
+      (inherit qtsvg)
+      (name "pyotherside")
+      (version (git-version "1.5.9" revision commit-ref))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/thp/pyotherside")
+               (commit commit-ref)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1kq8v2inwx4j9idsdxwkjas4nqyfwzwfwiiwpjqr8ggcx1z9gvi3"))))
+      (outputs '("out"))
+      (inputs
+       `(("qtbase" ,qtbase-5)
+         ("qtdeclarative" ,qtdeclarative)
+         ("qtsvg" ,qtsvg)))
+      (propagated-inputs
+       `(("python" ,python-wrapper)))
+      (native-inputs `())
+      (arguments
+       (substitute-keyword-arguments (package-arguments qtsvg)
+         ((#:tests? _ #f) #f))) ;; Plugin must be installed before testing
+      (home-page "https://thp.io/2011/pyotherside/")
+      (synopsis "Asynchronous Python 3 Bindings for Qt 5")
+      (description "A Qt plugin providing access to a Python 3 interpreter from
+QML for creating asynchronous mobile and Desktop UIs with Python.")
+      (license license:isc))))