diff mbox series

[bug#49123,05/24] gnu: Add python-filetype.

Message ID 20210620010742.4259-5-0x2d@disroot.org
State New
Headers show
Series [bug#49123,01/24] gnu: Add pyotherside. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

slg June 20, 2021, 1:07 a.m. UTC
* gnu/packages/python-xyz.scm (python-filetype): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54c7d91116..6831e2365b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26013,3 +26013,24 @@  up the mess made by various rich text editors and or copy-pasting to make
 styling of webpages simpler and more consistent.  It builds on the excellent
 HTML cleaner in lxml to make the result both valid and safe.")
     (license license:bsd-3)))
+
+(define-public python-filetype
+  (package
+    (name "python-filetype")
+    (version "1.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "filetype" version))
+       (sha256
+        (base32
+         "19vav4w8vvcnrps1mirjkrv4pr1khwn5ma6m5pgpxd4qip73wffs"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;; FIXME: obscure error in test
+    (home-page "https://github.com/h2non/filetype.py")
+    (synopsis "Python package for checking file type and MIME type")
+    (description "Small and dependency free Python package to infer file type
+and MIME type checking the magic numbers signature of a file or buffer.  This
+is a Python port from filetype Go package.")
+    (license license:x11)))