diff mbox series

[bug#49123,23/24] gnu: Add python-hsluv.

Message ID 20210620010742.4259-23-0x2d@disroot.org
State New
Headers show
Series [bug#49123,01/24] gnu: Add pyotherside. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

slg June 20, 2021, 1:07 a.m. UTC
* gnu/packages/python-xyz.scm (python-hsluv): New variable.
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

M July 15, 2021, 1:31 p.m. UTC | #1
slg via Guix-patches via schreef op za 19-06-2021 om 22:07 [-0300]:
> +(define-public python-hsluv
> +  (package
> +    (name "python-hsluv")
> +    (version "5.0.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "hsluv" version))
> +       (sha256
> +        (base32
> +         "1yi76w24rr7d8vva01jq6s4zv28w945l1vbf56j2azbakjr9ispz"))))
> +    (build-system python-build-system)
> +    (home-page "https://www.hsluv.org/")
> +    (synopsis "Human-friendly HSL")

HSLuv isn't HSL, so HSLuv isn't human-friendly HSL?

I think (synopsis "Convert between HSLuv and RGB colour coordinates")
would be more descriptive and more correct, in particular for people
who haven't ever heard of "HSL" or humans, and ‘human-friendly’ is
rather subjective.

> +    (description "HSLuv is a human-friendly alternative to HSL.")

‘16.4.4 Synopses and Descriptions’ in the manual has some guidelines
on synopses and descriptions.

> +    (license license:x11)))

LICENSE.txt is not the X11 license, as the following is missing:

  Except as contained in this notice, the name of the X Consortium shall
  not be used in advertising or otherwise to promote the sale, use or
  other dealings in this Software without prior written authorization
  from the X Consortium.

  X Window System is a trademark of X Consortium, Inc. 

Instead, it appears to be the expat license.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6dd42d5455..678e719b64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26150,3 +26150,20 @@  tools, IDE or directly modifying you source code into IPython with a
 higher and more powerful abstraction than the advanced texts
 modification tools that you find in advanced text editors and IDE.")
     (license license:lgpl3)))
+
+(define-public python-hsluv
+  (package
+    (name "python-hsluv")
+    (version "5.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hsluv" version))
+       (sha256
+        (base32
+         "1yi76w24rr7d8vva01jq6s4zv28w945l1vbf56j2azbakjr9ispz"))))
+    (build-system python-build-system)
+    (home-page "https://www.hsluv.org/")
+    (synopsis "Human-friendly HSL")
+    (description "HSLuv is a human-friendly alternative to HSL.")
+    (license license:x11)))