diff mbox series

[bug#49123,10/24] gnu: python-h2: Update to 4.0.0.

Message ID 20210620010742.4259-10-0x2d@disroot.org
State New
Headers show
Series [bug#49123,01/24] gnu: Add pyotherside. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

slg June 20, 2021, 1:07 a.m. UTC
* gnu/packages/python-web.scm (python-h2): Update to 4.0.0.
* gnu/packages/python-web.scm (python-h2): Update home-page
---
 gnu/packages/python-web.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

M July 18, 2021, 4:15 p.m. UTC | #1
slg via Guix-patches via schreef op za 19-06-2021 om 22:07 [-0300]:
> * gnu/packages/python-web.scm (python-h2): Update to 4.0.0.
> * gnu/packages/python-web.scm (python-h2): Update home-page
> ---
>  gnu/packages/python-web.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 1a391a5060..4ef8d71f45 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -919,13 +919,13 @@ and that could be anything you want.")
>  (define-public python-h2
>    (package
>      (name "python-h2")
> -    (version "3.2.0")
> +    (version "4.0.0")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri "h2" version))
>         (sha256
> -        (base32 "051gg30aca26rdxsmr9svwqm06pdz9bv21ch4n0lgi7jsvml2pw7"))))
> +        (base32 "0gar809k91d04ky3fqjidfxgbcdnj9hmm09csmz8aynnkl4wfymv"))))
>      (build-system python-build-system)
>      (arguments
>       `(#:phases
> @@ -939,7 +939,7 @@ and that could be anything you want.")
>      (propagated-inputs
>       `(("python-hpack" ,python-hpack)
>         ("python-hyperframe" ,python-hyperframe)))
> -    (home-page "https://github.com/python-hyper/hyper-h2")
> +    (home-page "https://github.com/python-hyper/h2")
>      (synopsis "HTTP/2 State-Machine based protocol implementation")
>      (description
>       "This module contains a pure-Python implementation of a HTTP/2 protocol

I verified the dependencies still build and reproducibility (using --check).
I also opened the tarball and there doesn't appear to be malware inside.
The diff between 3.2.0 and 4.0.0 doesn't seem suspicious, but I am not familiar
with how the HTTP/2 protocol works.

The new home page appears correct: the old home page redirects to the new.

This patch LGTM.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1a391a5060..4ef8d71f45 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -919,13 +919,13 @@  and that could be anything you want.")
 (define-public python-h2
   (package
     (name "python-h2")
-    (version "3.2.0")
+    (version "4.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "h2" version))
        (sha256
-        (base32 "051gg30aca26rdxsmr9svwqm06pdz9bv21ch4n0lgi7jsvml2pw7"))))
+        (base32 "0gar809k91d04ky3fqjidfxgbcdnj9hmm09csmz8aynnkl4wfymv"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -939,7 +939,7 @@  and that could be anything you want.")
     (propagated-inputs
      `(("python-hpack" ,python-hpack)
        ("python-hyperframe" ,python-hyperframe)))
-    (home-page "https://github.com/python-hyper/hyper-h2")
+    (home-page "https://github.com/python-hyper/h2")
     (synopsis "HTTP/2 State-Machine based protocol implementation")
     (description
      "This module contains a pure-Python implementation of a HTTP/2 protocol