From df6cac40e56957b8ad9177fa5e0ee925b875bbc0 Mon Sep 17 00:00:00 2001
From: nee <nee-git@hidamari.blue>
Date: Fri, 15 Mar 2019 23:04:15 +0100
Subject: [PATCH] gnu: Add edgar.
* gnu/packages/games.scm (edgar): New variable.
---
gnu/packages/games.scm | 48 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 47 insertions(+), 1 deletion(-)
@@ -25,7 +25,7 @@
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017 nee <nee-git@hidamari.blue>
+;;; Copyright © 2017, 2019 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
@@ -6276,3 +6276,49 @@ game field is extended to 4D space, which has to filled up by the gamer with
4D hyper cubes.")
(license license:gpl3)))
+(define-public edgar
+ (package
+ (name "edgar")
+ (version "1.30")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/riksweeney/edgar/releases/download/"
+ version "/edgar-" version "-1.tar.gz"))
+ (sha256
+ (base32
+ "0bhbs33dg0nb8wqlh6px1jj41j05f89ngdqwdkffabmjk7wq5isx"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f ; there are no tests
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "BIN_DIR=" (assoc-ref %outputs "out") "/bin/"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'fix-env
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
+ "/include/SDL/"))
+ #t)))))
+ (inputs `(("sdl" ,sdl)
+ ("sdl-img" ,sdl-image)
+ ("sdl-mixer" ,sdl-mixer)
+ ("sdl-ttf" ,sdl-ttf)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gnu-gettext" ,gnu-gettext)
+ ("libtool" ,libtool)
+ ("which" ,which)))
+ (synopsis "2d action platformer game")
+ (description "The Legend of Edgar is a 2D platform game with a persistent world.
+When Edgar's father fails to return home after venturing out one dark and stormy night,
+Edgar fears the worst: he has been captured by the evil sorcerer who lives in
+a fortress beyond the forbidden swamp.")
+ (home-page "https://www.parallelrealities.co.uk/games/edgar/")
+ (license license:gpl2+)))
--
2.20.1