diff mbox series

[bug#54796,v3,04/22] gnu: Add erlang-erlware-commons.

Message ID 3d46f7da1d14db0cbab7ae275b4807bcae3b94ab.1649436566.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add importer for hex.pm and rebar3 build-system for Erlang | expand

Commit Message

Hartmut Goebel April 8, 2022, 5:03 p.m. UTC
* gnu/packages/erlang.scm (erlang-erlware-commons): New variable.
---
 gnu/packages/erlang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

M April 9, 2022, 10:58 a.m. UTC | #1
Hartmut Goebel schreef op vr 08-04-2022 om 19:03 [+0200]:
> +    (native-inputs
> +     (list git))  ;; Required for tests

Maybe git-minimal/fixed, to avoid rebuilds if 'git' is updated.

Greetings,
MAxime.
Hartmut Goebel April 9, 2022, 3:33 p.m. UTC | #2
Am 09.04.22 um 12:58 schrieb Maxime Devos:
> Maybe git-minimal/fixed, to avoid rebuilds if 'git' is updated.

Done.
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 95a18e6f18..34761a4d64 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -246,3 +246,30 @@  Mozilla's canonical set.")
     (description "This package provides a helper library for termial colour
 printing extending the io:format syntax to add colours.")
     (license license:expat)))
+
+(define-public erlang-erlware-commons
+  (package
+    (name "erlang-erlware-commons")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri "erlware_commons" version))
+       (sha256
+        (base32 "18qam9xdzi74wppb0cj4zc8161i0i8djr79z8662m6d276f2jz5m"))))
+    (build-system rebar3-build-system)
+    (propagated-inputs
+     (list erlang-cf))
+    (native-inputs
+     (list git))  ;; Required for tests
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "TERM" "xterm")))))) ; enable color in logs
+    (home-page "http://erlware.github.io/erlware_commons/")
+    (synopsis "Additional standard library for Erlang")
+    (description "Erlware Commons is an Erlware project focused on all aspects
+of reusable Erlang components.")
+    (license license:expat)))