diff mbox series

[bug#54796,v3,19/22] gnu: Add rebar3-raw-deps.

Message ID 38f49c05eda35a1c0492583bd3a8fcc1e1cdf21f.1649436566.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add importer for hex.pm and rebar3 build-system for Erlang | expand

Commit Message

Hartmut Goebel April 8, 2022, 5:03 p.m. UTC
* gnu/packages/erlang.scm (rebar3-raw-deps): New variable.
---
 gnu/packages/erlang.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

M April 9, 2022, 11:49 a.m. UTC | #1
Hartmut Goebel schreef op vr 08-04-2022 om 19:03 [+0200]:
> +    (synopsis "Rebar3 plugin for supporting \"raw\" dependencies")
> +    (description "This plugin adds support for \"raw\" dependencies to
> +rebar3.")

The synopsis and description are practically identical here.  What is a
‘raw’ depency?  How does someone know if "raw" dependencies might be
useful for their purposes?

Greetings,
Maxime.
Hartmut Goebel April 9, 2022, 3:50 p.m. UTC | #2
Am 09.04.22 um 13:49 schrieb Maxime Devos:
> The synopsis and description are practically identical here.  What is a
> ‘raw’ depency?  How does someone know if "raw" dependencies might be
> useful for their purposes?

„raw deps” are non-OTP applications.

Rephrased into „This plugin provides support for handling non-OTP 
applications as a dependent libraries“.

(That's all I can tell based on the Readme and from trying to understand 
the code.)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 35681e9a73..8bd7ba3739 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -625,3 +625,20 @@  build configuration work.  @code{rebar3} also provides dependency management,
 enabling application writers to easily re-use common libraries from a variety
 of locations (git, hg, etc).")
     (license license:asl2.0)))
+
+(define-public rebar3-raw-deps
+  (package
+    (name "rebar3-raw-deps")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri "rebar3_raw_deps" version))
+       (sha256
+        (base32 "1pzmm3m8gb2s9jn8fp6shzgfmy4mvh2vdci0z6nsm74ma3ffh1i3"))))
+    (build-system rebar3-build-system)
+    (home-page "https://github.com/soranoba/rebar3_raw_deps")
+    (synopsis "Rebar3 plugin for supporting \"raw\" dependencies")
+    (description "This plugin adds support for \"raw\" dependencies to
+rebar3.")
+    (license license:expat)))