[bug#34926] gnu: libssh2: Update to 1.8.1 with a graft [security fixes].

Message ID 128204645081af4cc1e10f5aef21b9b4e6dc9d81.1553113916.git.leo@famulari.name
State Accepted
Headers show
Series [bug#34926] gnu: libssh2: Update to 1.8.1 with a graft [security fixes]. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Leo Famulari March 20, 2019, 8:31 p.m. UTC
Fixes CVE-2019-{3855,3856,3857,3858,3859,3860,3861,3862,3863}.
---
 gnu/packages/ssh.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Efraim Flashner March 20, 2019, 8:35 p.m. UTC | #1
Is the patch already in the repo or did you forget to attach it?
Leo Famulari March 20, 2019, 8:43 p.m. UTC | #2
On Wed, Mar 20, 2019 at 10:35:04PM +0200, Efraim Flashner wrote:
> Is the patch already in the repo or did you forget to attach it?

I'm not sure what happened but I did sent it with `git send-email`:

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34926#5
Leo Famulari March 21, 2019, 5:38 p.m. UTC | #3
I've pushed a variant of this patch as
af8f7eb4f2a664c2d0fb3faabaf2e80c72993ef6

Patch

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index dc81736f06..ec81844b93 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -111,6 +111,7 @@  applications.")
 (define-public libssh2
   (package
    (name "libssh2")
+   (replacement libssh2-1.8.1)
    (version "1.8.0")
    (source (origin
             (method url-fetch)
@@ -143,6 +144,21 @@  a server that supports the SSH-2 protocol.")
    (license license:bsd-3)
    (home-page "https://www.libssh2.org/")))
 
+(define-public libssh2-1.8.1
+  (package
+    (inherit libssh2)
+    (version "1.8.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                    "https://www.libssh2.org/download/libssh2-"
+                    version ".tar.gz"))
+             (sha256
+              (base32
+               "0ngif3ynk6xqzy5nlfjs7bsmfm81g9f145av0z86kf0vbgrigda0"))
+             (patches
+              (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))))
+
 (define-public openssh
   (package
    (name "openssh")