[bug#34687] Add toutenclic

Message ID 877edjpzx0.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#34687] Add toutenclic | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Nicolas Goaziou Feb. 28, 2019, 5:48 p.m. UTC
Hello,

This patch adds toutenclic.

Feedback welcome. Thank you.

Regards,

Comments

Leo Famulari March 15, 2019, 5 p.m. UTC | #1
On Thu, Feb 28, 2019 at 06:48:27PM +0100, Nicolas Goaziou wrote:
> From 60822718faf19412753daedec1b50924b2d267a6 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Thu, 28 Feb 2019 18:18:57 +0100
> Subject: [PATCH] gnu: Add toutenclic.
> 
> * gnu/packages/education.scm (toutenclic): New variable.

LGTM, thanks!
Nicolas Goaziou March 15, 2019, 11:32 p.m. UTC | #2
Hello,

Leo Famulari <leo@famulari.name> writes:

> On Thu, Feb 28, 2019 at 06:48:27PM +0100, Nicolas Goaziou wrote:
>> From 60822718faf19412753daedec1b50924b2d267a6 Mon Sep 17 00:00:00 2001
>> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
>> Date: Thu, 28 Feb 2019 18:18:57 +0100
>> Subject: [PATCH] gnu: Add toutenclic.
>> 
>> * gnu/packages/education.scm (toutenclic): New variable.
>
> LGTM, thanks!

Pushed as 3b2cf5c8262067501e88c2ffe5d7f96e04b17d17. Thank you.

Regards,
Nicolas Goaziou March 15, 2019, 11:33 p.m. UTC | #3
Pushed.

Patch

From 60822718faf19412753daedec1b50924b2d267a6 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Thu, 28 Feb 2019 18:18:57 +0100
Subject: [PATCH] gnu: Add toutenclic.

* gnu/packages/education.scm (toutenclic): New variable.
---
 gnu/packages/education.scm | 69 +++++++++++++++++++++++++++++++++++++-
 1 file changed, 68 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 5b899f4e78..80d3049956 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -4,7 +4,7 @@ 
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -51,6 +51,7 @@ 
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
   #:use-module (srfi srfi-1))
 
@@ -303,3 +304,69 @@  science for high school or college students.
 This package provides a @command{snap} executable calling @command{xdg-open}
 to open the application in a web browser, for offline usage.")
     (license license:agpl3+)))
+
+(define-public toutenclic
+  (package
+    (name "toutenclic")
+    (version "6.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.bipede.fr/downloads/logiciels/"
+                           "ToutEnClic-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1369m76fxmi2hgc2bbsq2jchcbh8q0qzml7600pqn8xiqrybvg9g"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f                      ;no test
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'build)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (share (string-append out "/share/toutenclic"))
+                    (pixmaps (string-append out "/share/pixmaps"))
+                    (bin (string-append out "/bin"))
+                    (executable "toutenclic.py"))
+               ;; Install icon.
+               (install-file "toutenclic.png" pixmaps)
+               ;; Move files into "share/" directory.
+               (mkdir-p share)
+               (copy-recursively "." share)
+               ;; Create executable in "bin/".
+               (mkdir-p bin)
+               (with-directory-excursion bin
+                 (symlink (string-append share "/" executable)
+                          executable)))
+             #t))
+         (add-after 'install 'create-desktop-file
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (applications (string-append out "/share/applications")))
+               (mkdir-p applications)
+               (call-with-output-file
+                   (string-append applications "/toutenclic.desktop")
+                 (lambda (file)
+                   (format file
+                           "[Desktop Entry]~@
+                            Name=ToutEnClic~@
+                            Comment=For schooling without difference~@
+                            Exec=~a/bin/toutenclic.py~@
+                            TryExec=~@*~a/bin/toutenclic.py~@
+                            Terminal=false~@
+                            Icon=toutenclic~@
+                            Type=Application~%"
+                           out)))
+               #t))))))
+    (inputs `(("python-pyqt" ,python-pyqt)))
+    (synopsis "School tools for physically disabled children")
+    (description "ToutEnClic is intended to facilitate the schooling
+of physically disabled children in ordinary schools.  It is both
+a multi-page virtual exercise book and a kit including pencil,
+scissors, glue, ruler, compass, protractor and square.  A virtual
+keyboard is also available if the child does not have any other
+specialized device.")
+    (home-page "https://bipede.fr/contrib/")
+    (license license:gpl3)))
-- 
2.21.0