diff mbox series

[bug#53882,07/24] gnu: Add ocaml-ppx-stable.

Message ID be81757eacaa67fb99e123fdcba99b6eb9858efe.1644350657.git.julien@lepiller.eu
State Accepted
Headers show
Series [bug#53882,01/24] import: opam: Accept tabulations. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Julien Lepiller Feb. 8, 2022, 8:14 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-stable): New variable.
---
 gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 44db4c0b12..1c87a35886 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6269,6 +6269,31 @@  (define-public ocaml-ppx-string
     (description "This extension provides a syntax for string interpolation.")
     (license license:expat)))
 
+(define-public ocaml-ppx-stable
+  (package
+    (name "ocaml-ppx-stable")
+    (version "0.14.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/janestreet/ppx_stable")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1sp1kn23qr0pfypa4ilvhqq5y11y13xpfygfl582ra9kik5xqfa1"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:test-target "tests"))
+    (propagated-inputs (list ocaml-base ocaml-ppxlib))
+    (properties `((upstream-name . "ppx_stable")))
+    (home-page "https://github.com/janestreet/ppx_stable")
+    (synopsis "Stable types conversions generator")
+    (description
+      "ppx_stable is a ppx extension for easier implementation of conversion
+functions between almost identical types.")
+    (license license:expat)))
+
 (define-public ocaml-ppx-base
   (package
     (name "ocaml-ppx-base")