[bug#34875] Add emacs-erc-image

Message ID CAAc=MEwhHwYj=2Vi2esxGXw=UKJCm=XdVuoTT57mOdNzEptvYg@mail.gmail.com
State Accepted
Headers show
Series [bug#34875] Add emacs-erc-image | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung March 15, 2019, 11:38 p.m. UTC
See attached.

Comments

Oleg Pykhalov March 16, 2019, 11:46 a.m. UTC | #1
Hello Brian,

Pushed as 2d164c9e96e9177f46976d93d5d457254e587eca to master with
upcased ‘erc’ and a changelog line in Git commit message.
--8<---------------cut here---------------start------------->8---
-      (synopsis "Show inlined images (png/jpg/gif/svg) in erc buffers")
+      (synopsis "Show inlined images (png/jpg/gif/svg) in ERC buffers")
--8<---------------cut here---------------end--------------->8---

Thanks,
Oleg.

Patch

From d9a99e66c3d2ce71489125603712260cedb76572 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 16 Mar 2019 00:37:34 +0100
Subject: [PATCH] gnu: Add emacs-erc-image.

---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f5936a2d23..022f82bfa2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9025,6 +9025,29 @@  arXiv, Google Scholar, Library of Congress, etc.
 @code{wmctrl} command-line window-management program.")
       (license license:gpl3+))))
 
+(define-public emacs-erc-image
+  (let ((commit "82fb3871f02e24b1e880770b9a3d187aab43d0f0")
+        (revision "1"))
+    (package
+      (name "emacs-erc-image")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/kidd/erc-image.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1q8mkf612fb4fjp8h4kbr107wn083iqfdgv8f80pcmil8y33dw9i"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/kidd/erc-image.el")
+      (synopsis "Show inlined images (png/jpg/gif/svg) in erc buffers")
+      (description "This plugin subscribes to hooks @code{erc-insert-modify-hook}
+and @code{erc-send-modify-hook} to download and show images.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-gtags
   (package
     (name "emacs-helm-gtags")
-- 
2.21.0