diff mbox series

[bug#64798,143/209] gnu: khelpcenter: use G-expressions.

Message ID tencent_984BE22F51E7B75CB1A4A4167F333E552505@qq.com
State New
Headers show
Series None | expand

Commit Message

Z572 July 23, 2023, 8:46 a.m. UTC
* gnu/packages/kde-systemtools.scm (khelpcenter)[arguments]:
Rewrite as G-expressions.
---
 gnu/packages/kde-systemtools.scm | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index 52a711a1bb..3a2d0e6cd3 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -26,6 +26,7 @@  (define-module (gnu packages kde-systemtools)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
+  #:use-module (guix gexp)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages freedesktop)
@@ -164,17 +165,17 @@  (define-public khelpcenter
            qtbase-5
            xapian))
     (arguments
-     `(#:tests? #f  ;; 1/1 test fails
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               ;; Since qt-wrap selectors do not wrap for /share/kf5
-               ;; directories, we need this so khelpcenter can find html4.css.
-               (wrap-program (string-append out "/bin/khelpcenter")
-                 `("XDG_DATA_DIRS" suffix
-                   (,(string-append (assoc-ref inputs "khtml") "/share"))))))))))
+     (list #:tests? #f ;;1/1 test fails
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'install 'wrap-executable
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            ;; Since qt-wrap selectors do not wrap for /share/kf5
+                            ;; directories, we need this so khelpcenter can find html4.css.
+                            (wrap-program (string-append #$output
+                                                         "/bin/khelpcenter")
+                              `("XDG_DATA_DIRS" suffix
+                                (,(string-append (assoc-ref inputs "khtml")
+                                                 "/share")))))))))
     (home-page "https://apps.kde.org/khelpcenter/")
     (synopsis "KDE documentation viewer")
     (description "KHelpCenter uses meta data files which describe the