diff mbox series

[bug#64798,066/209] gnu: kimageformats: use G-expressions.

Message ID tencent_447E6DD2A5366445FCB1E8509733969CD40A@qq.com
State New
Headers show
Series None | expand

Commit Message

Z572 July 23, 2023, 8:44 a.m. UTC
* gnu/packages/kde-frameworks.scm (kimageformats)[arguments]:
Rewrite as G-expressions.
---
 gnu/packages/kde-frameworks.scm | 48 +++++++++++++++++----------------
 1 file changed, 25 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index c28cf94b82..1dd1319c6f 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1811,29 +1811,31 @@  (define-public kimageformats
            openexr-2 ; for OpenEXR high dynamic-range images
            qtbase-5))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; make Qt render "offscreen", required for tests
-             (setenv "QT_QPA_PLATFORM" "offscreen")
-             (setenv "QT_PLUGIN_PATH"
-                     (string-append (getcwd) "/bin:"
-                                    (getenv "QT_PLUGIN_PATH")))))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (setenv "HOME" (getcwd))
-               ;; FIXME: I guess kde's qt no this fail.
-               ;; see https://invent.kde.org/frameworks/kimageformats/-/jobs/1046283
-               (invoke "ctest" "-E" "kimageformats-read-psd")))))
-       ;; FIXME: The header files of ilmbase (propagated by openexr) are not
-       ;; found when included by the header files of openexr, and an explicit
-       ;; flag needs to be set.
-       #:configure-flags
-       (list (string-append "-DCMAKE_CXX_FLAGS=-I"
-                            (assoc-ref %build-inputs "ilmbase")
-                            "/include/OpenEXR"))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda _
+              ;; make Qt render "offscreen", required for tests
+              (setenv "QT_QPA_PLATFORM" "offscreen")
+              (setenv "QT_PLUGIN_PATH"
+                      (string-append (getcwd) "/bin:"
+                                     (getenv "QT_PLUGIN_PATH")))))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (setenv "HOME"
+                        (getcwd))
+                ;; FIXME: I guess kde's qt no this fail.
+                ;; see https://invent.kde.org/frameworks/kimageformats/-/jobs/1046283
+                (invoke "ctest" "-E" "kimageformats-read-psd")))))
+      ;; FIXME: The header files of ilmbase (propagated by openexr) are not
+      ;; found when included by the header files of openexr, and an explicit
+      ;; flag needs to be set.
+      #:configure-flags #~(list (string-append "-DCMAKE_CXX_FLAGS=-I"
+                                               (assoc-ref %build-inputs
+                                                          "ilmbase")
+                                               "/include/OpenEXR"))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Plugins to allow QImage to support extra file formats")
     (description "This framework provides additional image format plugins for