diff mbox series

[bug#64798,181/209] gnu: Add wayland-protocols-next.

Message ID tencent_0FF94809582DCA667AAA49D6EF1FB74E5A06@qq.com
State New
Headers show
Series None | expand

Commit Message

Z572 July 23, 2023, 8:46 a.m. UTC
* gnu/packages/freedesktop.scm (wayland-protocols-next): New variable.
---
 gnu/packages/freedesktop.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 3bfc8b33ae..246a1cd0c9 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1237,6 +1238,19 @@  (define-public wayland-protocols
         . "https://wayland.freedesktop.org/releases.html")))
     (license license:expat)))
 
+(define-public wayland-protocols-next
+  (package (inherit wayland-protocols)
+           (name "wayland-protocols")
+           (version "1.32")
+           (source (origin
+                     (method url-fetch)
+                     (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+                                         name "/-/releases/" version "/downloads/"
+                                         name "-" version ".tar.xz"))
+                     (sha256
+                      (base32
+                       "04dsn79409mryxs6maq9kfhca97gvl3pr1ggjnv9d0hc6jfpjnbl"))))))
+
 (define-public wayland-utils
   (package
     (name "wayland-utils")