diff mbox series

[bug#70035,1/8] gnu: openimageio: Update to 2.5.9.0.

Message ID fc70e53680052e36a8c9493ba9552f53dc469618.1711551246.git.monego@posteo.net
State New
Headers show
Series Update and cleanup ASWF tools. | expand

Commit Message

Vinicius Monego March 27, 2024, 5:17 p.m. UTC
* gnu/packages/graphics.scm (openimageio): Update to 2.5.9.0.
[source]: Adjust tag prefix.
[inputs]: Replace openexr-2 with openexr, fmt-8 with fmt. Use package labels.

Change-Id: I7016f89c5b7c78cbc1ffeac23e5c0cefe2a8f43b
---
 gnu/packages/graphics.scm | 33 ++++++++++++++++-----------------
 1 file changed, 16 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9bc81a3a81..fcc7886b34 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1313,16 +1313,16 @@  (define-public openexr-2
 (define-public openimageio
   (package
     (name "openimageio")
-    (version "2.2.21.0")
+    (version "2.5.9.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/OpenImageIO/oiio")
-                    (commit (string-append "Release-" version))))
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0aicxbshzv1g9d8d08vsj1a9klaycxaifvvp565qjv70wyma2vkr"))))
+                "1djqna387vargrvf6dl53bsb7j36lvah4l9fvj0818s4sjkw4npd"))))
     (build-system cmake-build-system)
     ;; FIXME: To run all tests successfully, test image sets from multiple
     ;; third party sources have to be present.  For details see
@@ -1333,20 +1333,19 @@  (define-public openimageio
     (native-inputs
      (list pkg-config))
     (inputs
-     `(("boost" ,boost)
-       ("fmt" ,fmt-8)
-       ("libheif" ,libheif)
-       ("libpng" ,libpng)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libtiff" ,libtiff)
-       ("giflib" ,giflib)
-       ("openexr" ,openexr-2)
-       ("ilmbase" ,ilmbase)
-       ("pugixml" ,pugixml)
-       ("python" ,python-wrapper)
-       ("pybind11" ,pybind11)
-       ("robin-map" ,robin-map)
-       ("zlib" ,zlib)))
+     (list boost
+           fmt
+           libheif
+           libpng
+           libjpeg-turbo
+           libtiff
+           giflib
+           openexr
+           imath
+           pugixml
+           python-wrapper
+           pybind11
+           robin-map))
     (synopsis "C++ library for reading and writing images")
     (description
      "OpenImageIO is a library for reading and writing images, and a bunch of