diff mbox series

[bug#70035,3/8] gnu: Add partio.

Message ID 595ca17f154d7229f9a81beb8cd2622de0437e82.1711551246.git.monego@posteo.net
State New
Headers show
Series Update and cleanup ASWF tools. | expand

Commit Message

Vinicius Monego March 27, 2024, 5:17 p.m. UTC
* gnu/packages/graphics.scm (partio): New variable.

Change-Id: I680eebd45a3d38853a5907ee444f1ca4d54f2a44
---
 gnu/packages/graphics.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 50786e594b..55d87524db 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1519,6 +1519,43 @@  (define-public openmw-openscenegraph
            #~(modify-phases #$phases
                (delete 'copy-plugins)))))))))
 
+(define-public partio
+  (package
+    (name "partio")
+    (version "1.17.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/wdas/partio")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m0hrhzy3wlh5qi4rjkxrlcvgc1q41nqr2rwl6j07arr3z4mnpy1"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'configure 'set-LDFLAGS
+                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                   (setenv "LDFLAGS"
+                           (string-append
+                            "-Wl,-rpath="
+                            (assoc-ref outputs "out") "/lib")))))))
+    (native-inputs
+     (list python-wrapper swig))
+    (inputs
+     (list freeglut
+           libglvnd
+           zlib))
+    (home-page "https://partio.us/")
+    (synopsis "Library for particle IO and manipulation")
+    (description
+     "Partio is a C++ library for reading, writing and manipulating a variety
+of standard particle formats (GEO, BGEO, PTC, PDB, PDA).  It has a Python API
+and a collection of simple command-line tools.")
+    (license license:bsd-3)))
+
 (define-public povray
   (package
     (name "povray")